Agrégation LACP Windows et Cisco
>>> Windows 2012R2 et Cisco Catalyst 2960
Version PDF

Le but de cet article est de vous apprendre à configurer une Agrégation de lien (de type LACP) entre un serveur Windows serveur 2012 et un switch Cisco.


Sommaire :

I) Introduction
II) Configuration switch Cisco
III) Configuration serveur 2012R2


I) Introduction

Haut de page

Il existe plusieurs types d’agrégations de liens :
- Agrégation statique
- Agrégation dynamique serveur
- Agrégation dynamique LACP

Souvent les serveurs sont configurés en Agrégation statique (failover) ou en Agrégation dynamique serveur.
J’appelle "agrégation dynamique serveur", une Agrégation load balancing mais gérée seulement coté serveur. J’entends souvent dire, mon serveur gère l’Agrégation c’est transparent pour le switch. Avant il n’y avait pas de problème. Mais avec les nouveaux IOS de plus en plus performant, les switches peuvent générer des erreurs de Flapping comme celle-ci :

000420: Dec 21 23:42:42.534 MET: %SW_MATM-4-MACFLAP_NOTIF: Host 0012.efe0.5507 in vlan 4 is flapping between port Gi0/8 and port Gi0/7

La solution que je conseille, configurer une Agrégation de liens de type LACP.

Le protocole LACP : Link Aggregation Control Protocol (IEEE 802.3ad), est un protocole de niveau 2 du modèle OSI qui permet de grouper plusieurs ports physiques en une seule voie logique.

La norme décrit l’utilisation de multiples câbles réseau Ethernet ou un port parallèle pour augmenter la rapidité du lien au-delà des limites d’un câble ou d’un seul port, et d’accroître la redondance pour une plus grande disponibilité.

II) Configuration switch Cisco

Haut de page

La configuration du switch Cisco est simple. Nous allons configurer le LACP sur les interfaces 0/7 et 0/8.

SW-01#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
SW-01(config)#interface range fastEthernet 0/7 - 8
SW-01(config-if)#description "Serveur 2012R2 - LACP"
SW-01(config-if-range)#channel-group 1 mode active
Creating a port-channel interface Port-channel 1
SW-01(config-if-range)#channel-protocol lacp
SW-01(config-if-range)#exit

Maintenant on configure l’interface Port-channel 1.

SW-01(config)#interface port-channel 1
SW-01(config-if)#switchport mode access
SW-01(config-if)#switchport access vlan 10
SW-01(config-if)#description "Serveur 2012R2 - LACP"

Si maintenant on tape la commande "show run int fa 0/7" et "show run int fa 0/8" on peut voir que les commandes tapées sur l’interface Port-channel 1 sont redescendues sur les interfaces fa 0/7 et fa 0/8.

interface FastEthernet0/7
description "Serveur 2012R2 - LACP"
switchport access vlan 10
switchport mode access
channel-protocol lacp
channel-group 1 mode active
!
interface FastEthernet0/8
description "Serveur 2012R2 - LACP"
switchport access vlan 10
switchport mode access
channel-protocol lacp
channel-group 1 mode active

La configuration coté switch est terminée.

III) Configuration serveur 2012R2

Haut de page

- Ouvrez le "Gestionnaire de serveur". Cliquez sur "Configurer ce serveur local".

- Cliquez sur "Association de cartes réseau".

- Cliquez sur "TACHES".

- Cliquez sur "Nouvelle équipe", afin de définir un groupe d’interface.

- Définissez :

  • Un nom pour l’agrégation (Nom de l’équipe).
  • Cochez les interfaces de l’agrégation.
  • Sélectionner le mode "LACP".

Puis cliquez sur "OK".

Patientez pendant la configuration de l’Agrégation.

Une fois terminé le LACP fonctionne !!!

 
 
1er février 2016  --  N.Salmon
 
 
 
 
Commentaires :
Répondre à cet article
 
 
Se connecter | Copyright © 2016 Idum