Guide switch HP type Comware
>>> Réalisé sur un switch HP A5500
Version PDF

Cet article est un guide de prise en main des switches HP de type Comware (anciennement 3com). Je reprendrai les commandes de base, pour vous permettre de vous adaptez au firmware.


Sommaire :

I) Commandes de base
1) Hostname
2) Mise en place d’une bannière
3) Voir la version du switch
4) Description sur une interface
5) Gestion des utilisateurs
6) Redémarrer le switch

II) Gestion de la configuration
1) Consulter la configuration du switch
2) Enregistrer la configuration
3) Sauvegarder la configuration sur votre PC
4) Supprimer la configuration du switch
5) Restauration configuration depuis TFTP

III) Connexion et interface web
1) Interface terminal (console)
2) Telnet
3) SSH
4) HTTP & HTTPS

IV) Autres
1) Mise à l’heure manuel
2) Mise a l’heure via serveur NTP
3) Créer une route IP par défaut
4) Réaliser un relais DHCP

V) Gestion des vlans
1) Affecter une adresse IP à un vlan
2) Voir l’adresse IP des interfaces
3) Création de vlan
4) Affectation d’un vlan sur un port
5) Voir les ports contenus dans un vlan
6) Configuration d’un lien trunk
7) Configuration d’un lien Hybrid
8) Configuration agrégation LACP

VI) Interface Web
1) Connexion sur l’interface web
2) Hostname
3) Horloge
4) Affecter une adresse IP à un vlan
5) Gestion de la configuration
6) Voir la version du switch
7) Description sur une interface
8) Users et password
9) Redémarrer le switch


I) Commandes de base

Haut de page

Les équipements HP ne possèdent pas de mot de passe par défaut pour l’accès terminal :

Press ENTER to get started.
<HP>
#Apr 26 12:01:56:007 2000 HP SHELL/4/LOGIN:
Trap 1.3.6.1.4.1.25506.2.2.1.1.3.0.1: login from Console
%Apr 26 12:01:56:140 2000 HP SHELL/5/SHELL_LOGIN: Console logged in from aux0.
<HP>

Pour connaître les commandes possibles, utilisez le «  ? » :

<HP>?
User view commands:
 archive        Specify archive settings
 backup         Backup next startup-configuration file to TFTP server
 boot-loader    Set boot loader
 bootrom        Update/read/backup/restore bootrom
 brand          Set Original Equipment Manufacturer (BRAND) information
 cd             Change current directory
 cfd            Connectivity fault detection (IEEE 802.1ag)
 clock          Specify the system clock
 cluster        Run cluster command
 copy           Copy from one file to another
 crypto-digest  Compute the hash digest for a specified file
 debugging      Enable system debugging functions
 delete         Delete a file
 dir            List files on a file system
 display        Display current system information
 fixdisk        Recover lost chains in storage device
 format         Format the device
 free           Clear user terminal interface
 ftp            Open FTP connection
 ipc            Interprocess communication
 lock           Lock current user terminal interface
 mkdir          Create a new directory
 more           Display the contents of a file
 move           Move the file
 mtracert       Trace route to multicast source
 ntdp           Run NTDP commands
 oam            OAM protocol
 ping           Ping function
 pwd            Display current working directory
 quit           Exit from current command view
 reboot         Reboot system/board/card
 refresh        Do soft reset
 rename         Rename a file or directory
 reset          Reset operation
 restore        Restore next startup-configuration file from TFTP server
 rmdir          Remove an existing directory
 save           Save current configuration
 schedule       Schedule system task

Vous pouvez utiliser la touche « TAB » pour compléter votre commande.

Tout comme les switches HP de type procurve ou Cisco, pour configurer le switch vous devez entrer en mode "privilège". Pour entrer en mode privilège tapez "system-view".

<switch-A5500>system-view
[switch-A5500]

Vous pouvez observer que le prompt change une fois que l’on est connecté. Pour revenir en mode "user", tapez la commande "quit".

[switch-A5500]quit
<switch-A5500>

Dernière information importante, pour désactiver une commande avec un switch de type Comware, il faut tapez "undo". "Undo" remplace le "no" utilisé sur les autres systèmes.

1) Hostname

- Pour renommer le switch, tapez la commande "sysname HOSTNAME" :

<switch-A5500>system-view
System View: return to User View with Ctrl+Z.
[switch-A5500]sysname Switch-A5500

2) Mise en place d’une bannière

- Vous pouvez mettre en place une ou plusieurs bannières :

  • Legal banner : Apparaît après la déclaration du copyright ou de la licence. Pour continuer la connexion, l’utilisateur doit taper Y ou appuyer sur Entrée. Pour quitter le processus, l’utilisateur doit taper N.
  • Motd banner : apparaît après la bannière juridique et avant la bannière de connexion.
  • Login banner : Apparaît uniquement lorsque la sécurité « password » ou « authentication scheme » a été configuré.
  • Incoming banner : Apparaît pour les utilisateurs connectés en console.
  • Shell banner : Apparaît pour les utilisateurs connectés en SSH ou Telnet.

Exemple de bannière :

[Switch-A5500]header login &
Please input banner content, and quit with the character '&'.
-----------------------------------------
A V E R T I S S E M E N T / W A R N I N G
-----------------------------------------

AVERTISSEMENT :
Tout accès non autorisé a ce système est interdit et entrainera des
poursuites judiciaires. En accédant à ce système, vous acceptez que
vos actions puissent être surveillées en cas d'utilisation non autorisée.
&

Le symbole « & » est utilisé pour indiquer au switch le début et la fin de la bannière.

3) Voir la version du switch

- Pour voir la version, tapez la commande "display version" :

<HP>display version
HP Comware Platform Software
Comware Software, Version 5.20.99, Release 2220P02
Copyright (c) 2010-2013 Hewlett-Packard Development Company, L.P.
HP A5500-24G-SFP EI Switch with 2 Interface Slots uptime is 0 week, 0 day, 0 hour, 50 minutes

HP A5500-24G-SFP EI Switch with 2 Interface Slots with 1 Processor
256M    bytes SDRAM
32768K  bytes Flash Memory

Hardware Version is REV.C
CPLD Version is 002
Bootrom Version is 715
[SubSlot 0] 24SFP+8GE Hardware Version is REV.C

4) Description sur une interface

- Ajouter une description est souvent utile, tapez les commandes suivantes :

[Switch-A5500]interface GigabitEthernet 1/0/32  
[Switch-A5500-GigabitEthernet1/0/32]description PC-Management
[Switch-A5500-GigabitEthernet1/0/32]quit

5) Gestion des utilisateurs

- Création de l’utilisateur "admin".

[Switch-A5500]local-user admin
New local user added.

- Configurez le password "bonjour".

[Switch-A5500-luser-admin]password simple bonjour

- Configurez le niveau d’autorisation de l’utilisateur.

[Switch-A5500-luser-admin]authorization-attribute level 3

- Autorisez l’utilisateur à utiliser les services : ftp, web, telnet, ssh et terminal :

[Switch-A5500-luser-admin]service-type ftp        
[Switch-A5500-luser-admin]service-type ssh
[Switch-A5500-luser-admin]service-type terminal
[Switch-A5500-luser-admin]service-type telnet
[Switch-A5500-luser-admin]service-type web

6) Redémarrer le switch

- Pour redémarrer le switch, tapez la commande "reboot".

<Switch-A5500>reboot

II) Gestion de la configuration

Haut de page

1) Consulter la configuration du switch

- Pour visualiser la configuration, utilisez la commande "display current-configuration".

<HP>display current-configuration
#
version 5.20.99, Release 2220P02
#
sysname HP
#
irf mac-address persistent timer
irf auto-update enable
undo irf link-delay
#
domain default enable system
#
undo ip http enable
#
password-recovery enable
#
vlan 1

2) Enregistrer la configuration

- Pour sauvegarder la configuration dans la mémoire principale, la commande est "save main" ou tout simplement "save".

<HP>save main                              
The current configuration will be written to the device. Are you sure? [Y/N]:y
Please input the file name(*.cfg)[flash:/startup.cfg]
(To leave the existing filename unchanged, press the enter key):main.cfg
Validating file. Please wait....................
The current configuration is saved to the active main board successfully.
Configuration is saved to device successfully.

- Si vous souhaitez faire une sauvegarde de la configuration actuelle dans la mémoire Backup, la commande est "save backup".

<HP>save backup
The current configuration will be written to the device. Are you sure? [Y/N]:y
Please input the file name(*.cfg)[flash:/startup.cfg]
(To leave the existing filename unchanged, press the enter key):backup.cfg
Validating file. Please wait..................
The current configuration is saved to the active main board successfully.
Configuration is saved to device successfully.
  • HP A5500 possède 3 fichiers de sauvegardes dans la mémoire flash :
    • main.cfg
    • backup.cfg
    • startup.cfg -> Fichier de sauvegarde par défaut.

- Nous pouvons observer les trois fichiers en affichant le contenu de la mémoire flash :

<HP>dir
Directory of flash:/

  0     -rw-  13940314  Mar 21 2013 10:32:46   a5500ei-cmw520-r2220p02.bin
  1     drw-         -  Apr 26 2000 12:00:34   seclog
  2     -rw-      2567  Apr 26 2000 12:15:45   startup.cfg
  3     -rw-       151  Apr 26 2000 12:21:39   system.xml
  4     -rw-      2567  Apr 26 2000 12:21:08   main.cfg
  5     -rw-      2567  Apr 26 2000 12:21:43   backup.cfg

31496 KB total (17867 KB free)

- Nous pouvons ainsi choisir le fichier de sauvegarde qui sera utilisé au démarrage, via la commande "startup saved-configuration ?" :

<HP>startup saved-configuration ?
 backup.cfg  
 main.cfg    
 startup.cfg

3) Sauvegarder la configuration sur votre PC

- Transfert TFTP du fichier de configuration, via la commande "tftp XXX.XXX.XXX.XXX put Fichier.cfg" :

<HP>tftp 192.168.1.69 put main.cfg
 
 File will be transferred in binary mode
 Sending file to remote TFTP server. Please wait... \
 TFTP:     2637 bytes sent in 1 second(s).
 File uploaded successfully.

4) Supprimer la configuration du switch

- Pour supprimer la configuration backup ou main :

<Switch-A5500>reset saved-configuration ?
 backup  Backup config file
 main    Main config file
 <cr>    

<Switch-A5500>reset saved-configuration backup
The saved configuration file will be erased. Are you sure? [Y/N]:y
Configuration file in flash is being cleared.  
Please wait ...
..
MainBoard:
Configuration file is cleared.

5) Restauration configuration depuis TFTP

- Pour restaurer la configuration à partir d’un serveur TFTP :

  • On active l’interface 1/0/32
  • On télécharge le fichier de sauvegarde
  • On redémarre
[HP]int gi 1/0/32
[HP-GigabitEthernet1/0/32]undo shutdown
%Nov  2 15:45:29:405 2015 HP IFNET/3/LINK_UPDOWN: GigabitEthernet1/0/32 link status is UP.
%Nov  2 15:45:29:517 2015 HP IFNET/3/LINK_UPDOWN: Vlan-interface1 link status is UP.
%Nov  2 15:45:29:619 2015 HP IFNET/5/LINEPROTO_UPDOWN: Line protocol on the interface Vlan-int
[HP]quit
<HP>restore startup-configuration from 192.168.1.69 main.cfg
Restore next startup-configuration file from 192.168.1.69. Please wait..........
finished!
<HP>reboot

III) Connexion et interface web

Haut de page

1) Interface terminal (console)

- L’accès terminal étant déjà activé, nous allons juste configurer le terminal pour activer l’authentification :

[Switch-A5500]user-interface aux 0
[Switch-A5500-ui-aux0]authentication-mode scheme

2) Telnet

- Nous allons activer le serveur Telnet, puis nous allons activer l’authentification et pour finir définir le ou les protocoles autorisés sur l’interface VTY.

[Switch-A5500]telnet server enable
[Switch-A5500]user-interface vty 0 15
[Switch-A5500-ui-vty0-15]authentication-mode scheme
[Switch-A5500-ui-vty0-15]protocol inbound all

Nous pouvons autoriser seulement le Telnet en tapant la commande "protocol inbound telnet".

3) SSH

- Nous allons activer le serveur SSH, puis activer l’authentification et pour finir définir le ou les protocoles autorisés sur l’interface VTY.

[Switch-A5500]ssh server enable
[Switch-A5500]user-interface vty 0 15
[Switch-A5500-ui-vty0-15]authentication-mode scheme
[Switch-A5500-ui-vty0-15]protocol inbound all

Nous pouvons autoriser seulement le Telnet en tapant la commande "protocol inbound ssh".

- Si vous voulez générer une nouvelle clé publique plus importante :

[Switch-A5500]public-key local create rsa
Warning: The local key pair already exist.
Confirm to replace them? [Y/N]:y
The range of public key size is (512 ~ 2048).      
NOTES: If the key modulus is greater than 512,      
It will take a few minutes.    
Press CTRL+C to abort.
Input the bits of the modulus[default = 1024]:2048
Generating Keys...
+++++++++++++++++++++++++++++++++++++++++++++

4) HTTP & HTTPS

- Tapez la commande "undo ip http enable" pour arrêter le serveur HTTP. Puis tapez la commande "ip https enable" pour démarrer le serveur HTTPS :

[Switch-A5500]undo ip http enable
Info: HTTP server has been stopped!
[Switch-A5500]ip https enable

IV) Autres

Haut de page

1) Mise à l’heure manuel

- Pour définir l’heure sur le switch, tapez la commande suivante :

<Switch-A5500>clock datetime 15:14:30 11/02/2015

2) Mise a l’heure via serveur NTP

- Pour définir l’heure sur le switch via un serveur NTP, tapez la commande suivante :

[Switch-A5500]ntp-service unicast-server 192.168.1.69

3) Créer une route IP par défaut

- Définissez la route par défaut en tapant la commande "ip route 0.0.0.0 0.0.0.0 192.168.1.254" :

[Switch-A5500]ip route-static 0.0.0.0 0.0.0.0 192.168.1.254

- Affichez la table de routage pour vérifier :

[Switch-A5500]display ip routing-table
Routing Tables: Public
       Destinations : 5        Routes : 5

Destination/Mask    Proto  Pre  Cost         NextHop         Interface

0.0.0.0/0           Static 60   0            192.168.1.254   Vlan1
127.0.0.0/8         Direct 0    0            127.0.0.1       InLoop0
127.0.0.1/32        Direct 0    0            127.0.0.1       InLoop0
192.168.1.0/24      Direct 0    0            192.168.1.1     Vlan1
192.168.1.1/32      Direct 0    0            127.0.0.1       InLoop0

4) Réaliser un relay DHCP

- Pour un équipement Niveau 3, il est nécessaire d’activer le relais DHCP vers un serveur DHCP :

[Switch-A5500]dhcp enable
DHCP is enabled successfully!
[Switch-A5500]dhcp relay server-group 0 ip 192.168.1.69
[Switch-A5500-Vlan-interface1]dhcp relay server-select 0

V) Gestion des vlans

Haut de page

1) Affecter une adresse IP à un vlan

- Pour définir l’adresse IP sur l’interface vlan 1, tapez les commandes suivantes :

[Switch-A5500]interface Vlan-interface 1
[Switch-A5500-Vlan-interface1]ip address 192.168.1.1 255.255.255.0

2) Voir l’adresse IP des interfaces

- Pour visualiser les interfaces IP configurées sur le switch, tapez la commande "display ip interface brief"

<HP>display ip interface brief
*down: administratively down
(s): spoofing
Interface                     Physical Protocol IP Address      Description
Vlan1                         up       up       192.168.1.1     Vlan-inte...

3) Création d’un vlan

- Nous allons créer deux Vlans 97 et 99.

[Switch-A5500]vlan 99
[Switch-A5500-vlan99]name Users
[Switch-A5500-vlan99]quit
[Switch-A5500]vlan 97
[Switch-A5500-vlan97]name Serveurs

4) Affectation d’un vlan sur un port

1ère solution :

- La première solution consiste à entrer dans l’interface puis de lui définir le vlan :

[Switch-A5500]interface GigabitEthernet 1/0/25
[Switch-A5500-GigabitEthernet1/0/25]port access vlan 99

2ème solution :

- La deuxième solution consiste à entrer dans le Vlan puis de lui définir l’interface :

[Switch-A5500]vlan99
[Switch-A5500-vlan99]port GigabitEthernet 1/0/26

5) Voir les ports dans un vlan

- Pour voir les interfaces dans un vlan, il y a trois solutions :

  • On fait un "display vlan 99" pour afficher les interfaces configurées en access vlan 99 :
[Switch-A5500]display vlan 99
VLAN ID: 99
VLAN Type: static
Route Interface: not configured
Description: VLAN 0099
Name: Users
Tagged   Ports: none
Untagged Ports:
   GigabitEthernet1/0/26    GigabitEthernet1/0/27
  • On fait un "display interface gi 1/0/26 brief" puis on regarde la colonne PVID :
[Switch-A5500]display interface GigabitEthernet 1/0/26 brief
The brief information of interface(s) under bridge mode:
Link: ADM - administratively down; Stby - standby
Speed or Duplex: (a)/A - auto; H - half; F - full
Type: A - access; T - trunk; H - hybrid
Interface            Link Speed   Duplex Type PVID Description
GE1/0/26             ADM  auto    A      A    99
  • Pour afficher les interfaces de chaque vlan :
[Switch-A5500]display vlan all    
VLAN ID: 1
VLAN Type: static
Route Interface: configured
IPv4 address: 192.168.1.1
IPv4 subnet mask: 255.255.255.0
Description: VLAN 0001
Name: VLAN 0001
Tagged   Ports: none
Untagged Ports:
   GigabitEthernet1/0/1     GigabitEthernet1/0/2     GigabitEthernet1/0/3
   GigabitEthernet1/0/4     GigabitEthernet1/0/5     GigabitEthernet1/0/6
   GigabitEthernet1/0/7     GigabitEthernet1/0/8     GigabitEthernet1/0/9
   GigabitEthernet1/0/10    GigabitEthernet1/0/11    GigabitEthernet1/0/12


VLAN ID: 97
VLAN Type: static
Route Interface: not configured
Description: VLAN 0097
Name: Serveurs
Tagged   Ports: none
Untagged Ports:
   GigabitEthernet1/0/25

VLAN ID: 99
VLAN Type: static
Route Interface: not configured
Description: VLAN 0099
Name: Users
Tagged   Ports: none
Untagged Ports:
   GigabitEthernet1/0/26    GigabitEthernet1/0/27

6) Configuration d’un lien trunk

- Configuration d’un lien Trunk transportant les vlan 99 et 97 :

[Switch-A5500]interface gi 1/0/2
[Switch-A5500-GigabitEthernet1/0/2]port link-type trunk
[Switch-A5500-GigabitEthernet1/0/2]port trunk permit vlan 99 97

7) Configuration d’un lien Hybrid

- Configuration d’un lien Hybrid, permettant de transporter plusieurs Vlans taggués (1 et 97) et un vlan non taggué (99) :

[Switch-A5500]interface gi 1/0/2
[Switch-A5500-GigabitEthernet1/0/2]port link-type hybrid
[Switch-A5500-GigabitEthernet1/0/2]port hybrid vlan 1 97 tagged
[Switch-A5500-GigabitEthernet1/0/2]port hybrid vlan 99 untagged

Pour passer du l’interface du mode Trunk vers le mode Hybrid, vous devez d’abord taper la commande "port link-type access" puis "port link-type hybrid".

8) Configuration agrégation LACP

- Pour mettre en place une agrégation de liens utilisant le protocole LACP. L’agrégation de lien se fera sur les ports 1/0/23 et 1/0/24.

<Switch-A5400>system-view
[Switch-A5400]interface Bridge-Aggregation 1
[Switch-A5400-Bridge-Aggregation1]port link-type trunk
[Switch-A5400-Bridge-Aggregation1]port trunk permit vlan all
[Switch-A5400-Bridge-Aggregation1]link-aggregation mode dynamic
[Switch-A5400-Bridge-Aggregation1]quit
[Switch-A5400]interface range GigabitEthernet 1/0/23 GigabitEthernet 1/0/24
[Switch-A5400-if-range]port link-mode bridge
[Switch-A5400-if-range]port link-type trunk
[Switch-A5400-if-range]port trunk permit vlan all
Please wait........................................... Done.
Please wait........................................... Done.
[Switch-A5400-if-range]lacp period short
[Switch-A5400-if-range]port link-aggregation group 1

VI) Interface Web

Haut de page

1) Connexion sur l’interface web


-  Ouvrez le navigateur tapez l’adresse de switch.
-  Cliquez sur "Poursuivre avec ce site web".

-  Authentifiez-vous.

2) Hostname

- Dans le menu "Device", cliquez sur "Basic" puis sur l’onglet "System Name".

3) Horloge

a) Mise à l’heure manuel

- Dans le menu "Device", cliquez sur "System Time" puis sur l’onglet "System Time".

b) Mise à l’heure via serveur NTP

- Dans le menu "Device", cliquez sur "System Time" puis sur l’onglet "Network Time Protocol" :

  • Sélectionnez la source interface
  • Définissez une ou plusieurs adresse(s) de serveur NTP
  • Sélectionnez le Timezone

4) Affecter une adresse IP à un vlan

- Dans le menu "Network", cliquez sur "Vlan Interface" puis sur l’onglet "Create" :

  • Saisissez l’ID du Vlan
  • L’adresse et le masque

- Dans le menu "Network", cliquez sur "Vlan Interface" puis sur l’onglet "Summary".

- Dans le menu "Network", cliquez sur "IPv4 Routing" puis sur l’onglet "Create"

5) Gestion de la configuration

a) Enregistrer la configuration

- Dans le menu "Device", cliquez sur "Configuration" puis sur l’onglet "Save".

b) Sauvegarder la configuration sur votre PC

- Dans le menu "Device", cliquez sur "Configuration" puis sur l’onglet "Backup".

  • Cliquez sur "Backup"

c) Supprimer la configuration du switch

- Dans le menu "Device", cliquez sur "Configuration" puis sur l’onglet "Initialize".

d) Restauration de la configuration

- Dans le menu "Device", cliquez sur "Configuration" puis sur l’onglet "Restore".

6) Voir la version du switch

- Dans le menu "Summary", cliquez sur l’onglet "System Information".

- Toutes les informations apparaissent dans la colonne de droite :

7) Description sur une interface

- Dans le menu "Device", ensuite "Port Management" puis sur l’onglet "Setup".

  • Sélectionner l’interface ou les interfaces
  • Saisissez la description
  • Apply

8) Users et password

- Dans le menu "Device", puis sur "Users" et sur l’onglet "Create".

9) Redémarrer le switch

- Dans le menu "Device", puis sur "Device Maintenance" et sur l’onglet "Reboot".

 
 
30 novembre 2015  --  N.Salmon
 
 
 
 
Commentaires :
Répondre à cet article
 
 
Se connecter | Copyright © 2016 Idum