Configuration du NAT Statique sur routeur Cisco
>>> NAT Static
Version PDF

Cet article a pour but de vous apprendre à configurer le NAT statique sur un routeur Cisco. La fonctionnalité NAT permet de translater une adresse IP local en adresse IP publique.


Sommaire :

I) Introduction
1) Qu’est-ce que le NAT ?
2) Pourquoi as ton créé le NAT ?
3) Schéma réseau
II) Configuration de Base
1) Configuration du routeur R1
2) Configuration du routeur R0-1
3) Configuration du routeur R0-2
4) Configuration du routeur R2
III) NAT Static
1) Configuration du NAT sur R1
2) Configuration du NAT sur R2
3) Vérifications
IV) Téléchargement


I) Introduction


1) Qu’est-ce que le NAT ?

Commençons par la signification du NAT, Network Address Translation (en Français Translation d’Adresse Réseau).

On peut définir le NAT en trois types :
- Le NAT Statique
- Le Nat Dynamique
- Le NAT Overload appelé PAT

a) Le NAT Statique

Le NAT Statique permet de translater/transformer une adresse IP par une autre adresse IP.
Exemple :

Sur mon réseau local, je possède un serveur web que je souhaite rendre accessible depuis internet, mon serveur est configuré avec l’adresse IP 192.168.1.1.
Sur ma connexion internet, je possède plusieurs adresses IP public 80.22.33.45, 80.22.33.46, 80.22.33.47.
Le nom de mon site web hébergé sur mon serveur correspondra à l’adresse publique 80.22.33.47.
Je vais donc configurer une règle NAT Statique sur mon routeur pour translater toutes les requêtes arrivant sur 80.22.33.47 vers 192.168.1.1 de mon réseau local.

Plus techniquement, lorsque mon routeur va recevoir une requête arrivant d’internet ayant pour adresse de destination 80.22.33.47, celui-ci va substituer l’adresse de destination par l’adresse IP 192.168.1.1.

Pour résumer : Une adresse IP locale = Une adresse IP public.

b) Le NAT Dynamique

Le NAT Dynamique permet de translater plusieurs adresses IP par un pool d’adresses.
Exemple :

Sur mon réseau local, je possède 10 PC devant naviguer sur internet.
Sur ma connexion internet, je possède un pool d’adresses IP public 80.22.33.45 à 80.22.33.55 (soit 10 adresses public)
Je vais donc configurer une règle NAT dynamique sur mon routeur, pour translater automatiquement les requêtes qui partent de mes PC vers Internet.

Plus techniquement, lorsque mon routeur va recevoir une requête d’un PC pour naviguer sur internet, il va regarder la table de NAT et prendre la première adresse publique du pool disponible. Il va associer les deux adresses durant l’échange HTTP. Une fois l’échange http terminé, l’adresse sera libérée.

Pour résumer : X adresses IP locales = X adresses IP publiques

On pourrait configurer un réseau ayant par exemple 20 PC pour 10 adresses IP publiques. Mais si les 20 PC veulent naviguer sur internet en même temps, uniquement les 10 premiers pc pourront naviguer.

c) Le NAT Overload ou PAT

Le NAT Overload permet de translater plusieurs adresses IP par une adresse IP.
Exemple :

Sur mon réseau, je possède X PC devant naviguer sur Internet.
Sur ma connexion internet, je possède seulement une adresse IP Public 80.22.33.45.
Si j’utilise le NAT Statique, un seul de mes PC pourra naviguer sur Internet.
Si j’utilise le NAT Dynamique, mes X PC pourront naviguer sur Internet, mais seulement un seul à la fois.
Avec le NAT Overload, tous mes PC peuvent naviguer sur Internet en même temps.

Plus techniquement, lorsque mon routeur reçoit une requête, il crée une sorte de session en ajoutant un port sur la requête (port compris entre 0 et 65535).
- PC1 - 192.168.1.1 envoie la requête au routeur.
- Le routeur crée la session 192.168.1.1:1025 - 80.22.33.45:1025
- La requête est envoyée sur internet.
- Le serveur répond à l’adresse 80.22.33.45:1025
- Le routeur regarde dans sa table NAT et cherche la correspondance avec 80.22.33.45:1025
- Il trouve 192.168.1.1:1025
- Il envoie la réponse au PC1.

2) Pourquoi as ton créé le NAT ?

Avant la création du NAT, un PC ou un serveur voulant accéder à internet devait posséder une adresse IP publique.

Ceux qui ont développé Internet n’avaient pas imaginé à l’époque une telle évolution dans le monde. Ils ont donc créé Internet sur IPv4, en pensant que le nombre d’adresses proposé en IPv4 ne serait jamais utilisé à 100%.
Mais le développement d’Internet entre 1980 et 1990 dépassa toutes les attentes et les prévisions. Le nombre d’adresses IP publiques commençaient à diminuer. Pour ralentir cette progression, les ingénieurs/chercheurs ont inventé le NAT, permettant ainsi de réduire les besoins en adresses IP publiques.

3) Schéma réseau

Voici le réseau que nous allons mettre en place :

II) Configuration de base

Mise en place de la configuration de base sur les équipements.

1) Configuration du routeur R1

Mise en place de la configuration de base :

Router# configure terminal
Router(config)# no ip domain-lookup
Router(config)# hostname R1
R1(config)# line con 0
R1(config-line)# logging synchronous
R1(config-line)# exit

Configuration des interfaces du routeur :

R1(config)# interface gigabitEthernet 0/0
R1(config-if)# description "Interface connecte a Internet"
R1(config-if)# ip address 22.16.45.9 255.255.255.248
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# interface gigabitEthernet 0/1
R1(config-if)# description "Interface Reseau Client"
R1(config-if)# ip address 192.168.1.254 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit

Configuration du routage :

R1(config)# ip route 0.0.0.0 0.0.0.0 gi 0/0

Mise en place d’un serveur DHCP pour le réseau client :

R1(config)# ip dhcp pool LAN
R1(dhcp-config)# network 192.168.1.0 255.255.255.0
R1(dhcp-config)# dns-server 8.8.8.8
R1(dhcp-config)# default-router 192.168.1.254
R1(dhcp-config)# exit

Sauvegarde de la configuration :

R1(config)# end
R1# write memory

2) Configuration du routeur R0-1

Mise en place de la configuration de base :

Router# configure terminal
Router(config)# no ip domain-lookup
Router(config)# hostname R0-1
R0-1(config)# line con 0
R0-1(config-line)# logging synchronous
R0-1(config-line)# exit

Configuration des interfaces du routeur :

R0-1(config)# interface gigabitEthernet 0/0
R0-1(config-if)# description "Connecte au routeur R1"
R0-1(config-if)# ip address 22.16.45.14 255.255.255.248
R0-1(config-if)# no shutdown
R0-1(config-if)# exit
R0-1(config)# interface serial 0/0/0
R0-1(config-if)# description "Connecte au routeur R0-2"
R0-1(config-if)# ip address 52.69.21.33 255.255.255.252
R0-1(config-if)# no shutdown
R0-1(config-if)# exit

Configuration du routage :

R0-1(config)# ip route 8.8.8.0 255.255.255.240 52.69.21.34

Sauvegarde de la configuration :

R0-1(config)# end
R0-1# write memory

3) Configuration du routeur R0-2

Mise en place de la configuration de base :

Router# configure terminal
Router(config)# no ip domain-lookup
Router(config)# hostname R0-2
R0-2(config)# line con 0
R0-2(config-line)# logging synchronous
R0-2(config-line)# exit

Configuration des interfaces du routeur :

R0-2(config)# interface gigabitEthernet 0/0
R0-2(config-if)# description "connecte au routeur R2"
R0-2(config-if)# ip address 8.8.8.14 255.255.255.240
R0-2(config-if)# no shutdown
R0-2(config-if)# exit
R0-2(config)# interface serial 0/0/0
R0-2(config-if)# description "Connecte au routeur R0-1"
R0-2(config-if)# ip address 52.69.21.34 255.255.255.252
R0-2(config-if)# no shutdown
R0-2(config-if)# exit

Configuration du routage :

R0-2(config)# ip route 22.16.45.8 255.255.255.248 52.69.21.33

Sauvegarde de la configuration :

R0-2(config)# end
R0-2# write memory

4) Configuration du routeur R2

Mise en place de la configuration de base :

Router# configure terminal
Router(config)# no ip domain-lookup
Router(config)# hostname R2
R2(config)# line con 0
R2(config-line)# logging synchronous
R2(config-line)# exit

Configuration des interfaces du routeur :

R2(config)# interface gigabitEthernet 0/0
R2(config-if)# description "Interface connecte a Internet"
R2(config-if)# ip address 8.8.8.1 255.255.255.240
R2(config-if)# no shutdown
R2(config-if)# exit
R2(config)# interface gigabitEthernet 0/1
R2(config-if)# description "Interface connecte au site web"
R2(config-if)# ip address 192.168.2.254 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)# exit

Configuration du routage :

R2(config)# ip route 0.0.0.0 0.0.0.0 8.8.8.14

Sauvegarde de la configuration :

R2(config)# end
R2# write memory

Comme vous pouvez le voir, les routeurs R0-1 et R0-2 ne connaissent pas les réseaux 192.168.1.0 et 192.168.2.0.

Avant de configurer le NAT, faites un ping du serveur pour observer que le PC n’arrive pas à pinguer le serveur, alors que le routeur R2 ping le serveur.

- Ping depuis le PC :

- Ping depuis le R1 :

- Ping depuis le R2 :

- Vous pouvez aussi observer qu’un ping depuis le routeur R1 vers l’adresse publique du routeur R2 fonctionne :

III) NAT Static


1) Configuration du NAT sur R1

Nous allons commencer par créer la règle NAT.

R1(config)# ip nat inside source static 192.168.1.10 22.16.45.10

- L’adresse IP 192.168.1.10 correspond à l’adresse IP de notre PC-2.
- Et l’adresse IP 22.16.45.10 correspond à l’adresse IP natté de notre PC-2

Deuxième étape, il faut identifier l’interface LAN :

R1(config)# interface gigabitEthernet 0/1
R1(config-if)# ip nat inside
R1(config-if)# exit

Dernière étape, il faut identifier l’interface WAN :

R1(config)# interface gigabitEthernet 0/0
R1(config-if)# ip nat outside
R1(config-if)# exit

Pour finir, sauvegarde de la configuration :

R1(config)# end
R1# write memory

Pour finir, nous allons faire quelques tests :

- Faite un ping du PC-2 "192.168.1.10" depuis R0-1 :

  • Le ping ne fonctionne pas car le réseau n’est pas routé, il ne peut pas communiquer avec le réseau publique.

- Faite un ping du PC-2 "22.16.45.10" depuis R0-1 :

  • Nous utilisons cette fois l’adresse natté de PC-2, le ping fonctionne.

Le PC-1 n’ayant pas d’adresse Nattée, il ne peut pas communiquer avec le réseau public.

2) Configuration du NAT sur R2

Même chose sur R2.

R2(config)# ip nat inside source static 192.168.2.1 8.8.8.8

- L’adresse IP 192.168.2.1 correspond à l’adresse IP de notre serveur web.
- Et l’adresse IP 8.8.8.8 correspond à l’adresse IP natté de notre serveur web.

Deuxième étape, il faut identifier l’interface LAN :

R2(config)# interface gigabitEthernet 0/1
R2(config-if)# ip nat inside
R2(config-if)# exit

Dernière étape, il faut identifier l’interface WAN :

R2(config)# interface gigabitEthernet 0/0
R2(config-if)# ip nat outside
R2(config-if)# exit

Pour finir, sauvegarde de la configuration :

R2(config)# end
R2# write memory

Pour finir, nous allons faire quelques tests :

- Faite un ping du serveur web "192.168.2.1" depuis R0-2 :

  • Le ping ne fonctionne pas car le réseau n’est pas routé, il ne peut pas communiquer avec le réseau publique.

- Faite un ping du serveur web "8.8.8.8" depuis R0-2 :

  • Nous utilisons cette fois l’adresse nattée de PC-2, le ping fonctionne.

3) Vérifications

Pour observer les translations sur R1, tapez la commande :

R1# show ip nat translations

exemple :

Même chose on observe les translations sur R2 :

R2# show ip nat translations

exemple :

Dernier test, depuis PC-2, ouvrez le navigateur pour essayer d’accéder au site web en tapant l’adresse 8.8.8.8 :

IV) Téléchargement

Je vous propose le fichier Packet Tracert suivant. Il récapitule la configuration du PAT.

PNG - 12.3 ko
 
 
14 avril 2015  --  N.Salmon
 
 
 
 
Commentaires :
Répondre à cet article

  •  Configuration du NAT Statique sur routeur Cisco    > 20 août 2015 23:03, par serge

    Bonjour,
    merci pour votre réponse
    A quand un exercice avec call manager ?

    Cordialement


    •  Configuration du NAT Statique sur routeur Cisco    > 26 août 2015 09:45, par N.Salmon

      Bonjour,

      Concernant l’exercice Call manager, il me manque du temps pour réaliser tous les articles que je voudrais. Je suis actuellement sur une maquette Windows Server 2012 R2. Je ferai d’autres articles sur Call Manager mais pas tout de suite.

      @Bientot
      N.Salmon


  •  Configuration du NAT Statique sur routeur Cisco    > 20 août 2015 18:21, par serge

    Bonjour
    Un grand merci pour votre site toujours aussi excellent.
    Un exercice sur la voix sur IP avec call manager Cisco serait génial.
    il y a une erreur je pense
    ce n’est pas le réseau 22.16.45.4/29
    mais plutôt 22.16.45.8/29
    si on tient compte des adresses sur les routeurs

    Cordialement


    •  Configuration du NAT Statique sur routeur Cisco    > 20 août 2015 20:26, par N.Salmon

      Bonjour,

      Effectivement la conf était bonne, mais une coquille était bien présente dans l’image.

      Je vous remercie.

      @bientôt sur Idum.

      >> N.Salmon

 
 
Se connecter | Copyright © 2016 Idum