Configuration du PAT sur routeur Cisco
>>> PAT appelé aussi NAT Overload
Version PDF

Cet article a pour but de vous apprendre à configurer le PAT sur un routeur Cisco. La fonctionnalité PAT permet de translater X adresses IP en une seule adresse IP.


Sommaire :

I) Introduction
1) Qu’est-ce que le NAT ?
2) Pourquoi as ton créé le NAT ?
3) Schéma réseau
II) Configuration de Base
1) Configuration du routeur R1
2) Configuration du routeur R0-1
3) Configuration du routeur R0-2
4) Configuration du routeur R2
III) NAT Overload
1) Configuration du NAT
2) Vérifications
IV) Téléchargement


I) Introduction


1) Qu’est-ce que le NAT ?

Commençons par la signification du NAT, Network Address Translation (en Français Translation d’Adresse Réseau).

On peut définir le NAT en trois types :
- Le NAT Statique
- Le Nat Dynamique
- Le NAT Overload appelé PAT

a) Le NAT Statique

Le NAT Statique permet de translater/transformer une adresse IP par une autre adresse IP.
Exemple :

Sur mon réseau local, je possède un serveur web que je souhaite rendre accessible depuis internet, mon serveur est configuré avec l’adresse IP 192.168.1.1.
Sur ma connexion internet, je possède plusieurs adresses IP public 80.22.33.45, 80.22.33.46, 80.22.33.47.
Le nom de mon site web hébergé sur mon serveur correspondra à l’adresse publique 80.22.33.47.
Je vais donc configurer une règle NAT Statique sur mon routeur pour translater toutes les requêtes arrivant sur 80.22.33.47 vers 192.168.1.1 de mon réseau local.

Plus techniquement, lorsque mon routeur va recevoir une requête arrivant d’internet ayant pour adresse de destination 80.22.33.47, celui-ci va substituer l’adresse de destination par l’adresse IP 192.168.1.1.

Pour résumer : Une adresse IP locale = Une adresse IP public.

b) Le NAT Dynamique

Le NAT Dynamique permet de translater plusieurs adresses IP par un pool d’adresses.
Exemple :

Sur mon réseau local, je possède 10 PC devant naviguer sur internet.
Sur ma connexion internet, je possède un pool d’adresses IP public 80.22.33.45 à 80.22.33.55 (soit 10 adresses public)
Je vais donc configurer une règle NAT dynamique sur mon routeur, pour translater automatiquement les requêtes qui partent de mes PC vers Internet.

Plus techniquement, lorsque mon routeur va recevoir une requête d’un PC pour naviguer sur internet, il va regarder la table de NAT et prendre la première adresse publique du pool disponible. Il va associer les deux adresses durant l’échange HTTP. Une fois l’échange http terminé, l’adresse sera libérée.

Pour résumer : X adresses IP locales = X adresses IP publiques

On pourrait configurer un réseau ayant par exemple 20 PC pour 10 adresses IP publiques. Mais si les 20 PC veulent naviguer sur internet en même temps, uniquement les 10 premiers pc pourront naviguer.

c) Le NAT Overload ou PAT

Le NAT Overload permet de translater plusieurs adresses IP par une adresse IP.
Exemple :

Sur mon réseau, je possède X PC devant naviguer sur Internet.
Sur ma connexion internet, je possède seulement une adresse IP Public 80.22.33.45.
Si j’utilise le NAT Statique, un seul de mes PC pourra naviguer sur Internet.
Si j’utilise le NAT Dynamique, mes X PC pourront naviguer sur Internet, mais seulement un seul à la fois.
Avec le NAT Overload, tous mes PC peuvent naviguer sur Internet en même temps.

Plus techniquement, lorsque mon routeur reçoit une requête, il crée une sorte de session en ajoutant un port sur la requête (port compris entre 0 et 65535).
- PC1 - 192.168.1.1 envoie la requête au routeur.
- Le routeur crée la session 192.168.1.1:1025 - 80.22.33.45:1025
- La requête est envoyée sur internet.
- Le serveur répond à l’adresse 80.22.33.45:1025
- Le routeur regarde dans sa table NAT et cherche la correspondance avec 80.22.33.45:1025
- Il trouve 192.168.1.1:1025
- Il envoie la réponse au PC1.

2) Pourquoi as ton créé le NAT ?

Avant la création du NAT, un PC ou un serveur voulant accéder à internet devait posséder une adresse IP publique.

Ceux qui ont développé Internet n’avaient pas imaginé à l’époque une telle évolution dans le monde. Ils ont donc créé Internet sur IPv4, en pensant que le nombre d’adresses proposé en IPv4 ne serait jamais utilisé à 100%.
Mais le développement d’Internet entre 1980 et 1990 dépassa toutes les attentes et les prévisions. Le nombre d’adresses IP publiques commençaient à diminuer. Pour ralentir cette progression, les ingénieurs/chercheurs ont inventé le NAT, permettant ainsi de réduire les besoins en adresses IP publiques.

3) Schéma réseau

Voici le réseau que nous allons mettre en place :

PNG - 30.4 ko

II) Configuration de base

Mise en place de la configuration de base sur les équipements.

Petite informations concernant l’adressage IP :
- Le PC est en DHCP, il récupère une adresse IP dans le réseau 192.168.1.0/24. La gateway 192.168.1.254 et le serveur DNS 8.8.8.8.
- Le serveur Web est statique, il a pour adresse IP 8.8.8.8/24.

1) Configuration du routeur R1

Mise en place de la configuration de base :

Router# configure terminal
Router(config)# no ip domain-lookup
Router(config)# hostname R1
R1(config)# line con 0
R1(config-line)# logging synchronous
R1(config-line)# exit

Configuration des interfaces du routeur :

R1(config)# interface gigabitEthernet 0/0
R1(config-if)# description "Interface connecte a Internet"
R1(config-if)# ip address 22.16.45.5 255.255.255.252
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# interface gigabitEthernet 0/1
R1(config-if)# description "Interface Reseau Client"
R1(config-if)# ip address 192.168.1.254 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit

Configuration du routage :

R1(config)# ip route 0.0.0.0 0.0.0.0 gi 0/0

Mise en place d’un serveur DHCP pour le réseau client :

R1(config)# ip dhcp pool LAN
R1(dhcp-config)# network 192.168.1.0 255.255.255.0
R1(dhcp-config)# dns-server 8.8.8.8
R1(dhcp-config)# default-router 192.168.1.254
R1(dhcp-config)# exit

Sauvegarde de la configuration :

R1(config)# end
R1# write memory

2) Configuration du routeur R0-1

Mise en place de la configuration de base :

Router# configure terminal
Router(config)# no ip domain-lookup
Router(config)# hostname R0-1
R0-1(config)# line con 0
R0-1(config-line)# logging synchronous
R0-1(config-line)# exit

Configuration des interfaces du routeur :

R0-1(config)# interface gigabitEthernet 0/0
R0-1(config-if)# description "Connecte au routeur R1"
R0-1(config-if)# ip address 22.16.45.6 255.255.255.252
R0-1(config-if)# no shutdown
R0-1(config-if)# exit
R0-1(config)# interface serial 0/0/0
R0-1(config-if)# description "Connecte au routeur R0-2"
R0-1(config-if)# ip address 52.69.21.33 255.255.255.252
R0-1(config-if)# clock rate 2000000
R0-1(config-if)# no shutdown
R0-1(config-if)# exit

Configuration du routage :

R0-1(config)# ip route 81.52.63.32 255.255.255.252 52.69.21.34
R0-1(config)# ip route 8.8.8.0 255.255.255.0 52.69.21.34

Sauvegarde de la configuration :

R0-1(config)# end
R0-1# write memory

3) Configuration du routeur R0-2

Mise en place de la configuration de base :

Router# configure terminal
Router(config)# no ip domain-lookup
Router(config)# hostname R0-2
R0-2(config)# line con 0
R0-2(config-line)# logging synchronous
R0-2(config-line)# exit

Configuration des interfaces du routeur :

R0-2(config)# interface gigabitEthernet 0/0
R0-2(config-if)# description "connecte au routeur R2"
R0-2(config-if)# 81.52.63.34 255.255.255.252
R0-2(config-if)# no shutdown
R0-2(config-if)# exit
R0-2(config)# interface serial 0/0/0
R0-2(config-if)# description "Connecte au routeur R0-1"
R0-2(config-if)# ip address 52.69.21.34 255.255.255.252
R0-2(config-if)# no shutdown
R0-2(config-if)# exit

Configuration du routage :

R0-2(config)# ip route 22.16.45.4 255.255.255.252 52.69.21.33
R0-2(config)# ip route 8.8.8.0 255.255.255.0 81.52.63.33

Sauvegarde de la configuration :

R0-2(config)# end
R0-2# write memory

4) Configuration du routeur R2

Mise en place de la configuration de base :

Router# configure terminal
Router(config)# no ip domain-lookup
Router(config)# hostname R2
R2(config)# line con 0
R2(config-line)# logging synchronous
R2(config-line)# exit

Configuration des interfaces du routeur :

R2(config)# interface gigabitEthernet 0/0
R2(config-if)# description "Interface connecte a Internet"
R2(config-if)# ip address 81.52.63.33 255.255.255.252
R2(config-if)# no shutdown
R2(config-if)# exit
R2(config)# interface gigabitEthernet 0/1
R2(config-if)# description "Interface connecte au site web"
R2(config-if)# ip address 8.8.8.254 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)# exit

Configuration du routage :

R2(config)# ip route 0.0.0.0 0.0.0.0 81.52.63.34

Sauvegarde de la configuration :

R2(config)# end
R2# write memory

Comme vous pouvez le voir, les routeurs R0-1, R0-2 et R2 ne connaissent pas le réseau 192.168.1.0

Avant de configurer le NAT, faites un ping du serveur pour observer que le PC n’arrive pas à pinguer le serveur, alors que le routeur R1 ping le serveur.

- Ping depuis le PC :

- Ping depuis le R1 :

III) NAT Overload


1) Configuration du NAT

Nous allons commencer par créer une ACL pour sélectionner les réseaux qui utiliseront le NAT.

R1(config)# ip access-list standard PAT
R1(config-std-nacl)# permit 192.168.1.0 0.0.0.255
R1(config-std-nacl)# exit

Deuxième étape, nous allons créer une relation entre access-list et l’interface WAN.

R1(config)# ip nat inside source list PAT interface gi 0/0 overload


- List 1 : Correspond à l’ACL 1

Troisième étape, il faut identifier l’interface LAN :

R1(config)# interface gigabitEthernet 0/1
R1(config-if)# ip nat inside
R1(config-if)# exit

Dernière étape, il faut identifier l’interface WAN :

R1(config)# interface gigabitEthernet 0/0
R1(config-if)# ip nat outside
R1(config-if)# exit

Pour finir, sauvegarde de la configuration :

R1(config)# end
R1# write memory

Pour finir, nous allons faire quelques tests :

- Faite un ping du serveur web "8.8.8.8" :

- Ouvrez un navigateur pour accéder au site web "www.olymp.com" :

2) Vérifications

Pour observer les translations, tapez la commande :

R1# show ip nat translations

exemple :

IV) Téléchargement

Je vous propose le fichier Packet Tracert suivant. Il récapitule la configuration du PAT.

PNG - 12.3 ko
 
 
7 novembre 2014  --  N.Salmon
 
 
 
 
Commentaires :
Répondre à cet article

  •  Configuration du PAT sur routeur Cisco    > 26 janvier 2015 19:01, par Laurent OLIVIER

    Bonsoir,

    Une bonne aide à la mise en oeuvre de NAT/PAT.

    Il y a cependant une confusion pour le réseau entre R0-2 et R2 : est-ce le réseau 81.52.63.32/30 (étiquette visuelle sous PT) ou le réseau 87.52.63.32/30 (réseau effectivement configuré et routé).

    Pour un néophyte... c’est déroutant ! et ça apprend à debugger !

    Il manque aussi dans le texte support des précisions pour la configuration du serveur (ip/dns) et du PC (DHCP).
    Ne faudrait-il pas une commande "clock rate 64000", coté DCE, pour la liaison entre R0-1 et R0-2 ? Ca "marche" sans, mais est-ce une gentillesse de packet-tracer ?

    Merci encore


    •  Configuration du PAT sur routeur Cisco    > 4 février 2015 16:58, par N.Salmon

      Bonjour,

      Effectivement il y avait une petite coquille avec le réseau 87.52.63.32 et 81.52.63.32. Je viens de corriger l’article ainsi que le fichier Packet Tracert.

      J’ai aussi ajouté des informations sur les adresses IP du PC et du serveur.

      Merci.

 
 
Se connecter | Copyright © 2016 Idum