Agrégation de liens avec LACP sur Cisco
>>> LACP : Link Aggregation Control Protocol
Version PDF

Ce cours a pour but d’apprendre à configurer une agrégation de liens sur des switchs Cisco. Puis apprendre à observer le lien.


Sommaire :

I) Introduction
1) Principe de fonctionnement
2) Schéma réseau
II) Configuration
1) Configuration Switch 1
2) Configuration Switch 2
III) Test de fonctionnement


I) Introduction

L’agrégation de liens est une notion de réseau informatique décrivant l’utilisation de plusieurs câbles ou ports réseau afin d’accroître le débit d’un lien au-delà des limites d’un seul lien, ainsi que d’accroître la redondance pour une meilleure disponibilité. La plupart des implémentations sont aujourd’hui conformes à la clause 43 de la norme Ethernet IEEE 802.3-2005, plus souvent rencontrée sous le nom « IEEE 802.3ad ».

1) Principe de fonctionnement

Link Aggregation Control Protocol (LACP) est un protocole standardisé par l’IEEE qui est implémenté par différents constructeurs. Il fournit un mécanisme permettant de contrôler le groupement de plusieurs ports physiques en un canal logique de communication.
Le principe de fonctionnement consiste à émettre des paquets LACP vers l’équipement partenaire, directement connecté et configuré pour utiliser LACP. Le mécanisme LACP va permettre d’identifier si l’équipement en face supporte LACP, et groupera les ports configurés de manière similaires (vitesse, mode duplex, VLAN, trunk de vlan, etc...)
Un équipement configuré pour utiliser LACP peut fonctionner en trois modes :

- passif : l’équipement n’initiera pas de négociation LACP. Il répondra uniquement aux sollicitations des équipements « partenaires ».
- actif : l’équipement initiera les négociations LACP.
- on : l’équipement suppose que l’équipement partenaire est également dans ce mode et fera de l’agrégation de liens

2) Schéma réseau

II) Configuration

Nous allons configurer nos deux switchs, pour créer un lien d’agrégation comprenant les deux ports Gigabit des deux switchs. Nous aurons alors un lien logique avec une bande-passante de 2gbit/s.
Nous commencerons par créer trois Vlans (100, 200, 300). Nous configurerons les 4 ports gigabits dans le groupe "Port-channel" numéro 1. Puis nous allons configurer l’interface port-channel 1 en mode trunk.

1) Configuration Switch 1

a) Création des Vlans

Pour créer les Vlans nous tapons les commandes suivantes :

Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch1(config)#vlan 100
Switch1(config-vlan)#name SRV
Switch1(config-vlan)#exit
Switch1(config)#vlan 200
Switch1(config-vlan)#name User
Switch1(config-vlan)#exit
Switch1(config)#vlan 300
Switch1(config-vlan)#name Guest
Switch1(config-vlan)#exit

b) Configuration des interfaces

Nous allons maintenant configurer les interfaces Gigabit faisant partie de notre agrégation.

Switch1(config)#interface range gigabitEthernet 0/1 - 2
Switch1(config-if-range)#channel-group 1 mode active
Switch1(config-if-range)#channel-protocol lacp
Switch1(config-if-range)#exit

c) Configuration de l’interface port-channel

Nous allons configurer notre interface port-channel 1 en mode trunk. La configuration appliquée sur le port-channel sera automatiquement ré-appliquée sur les interfaces du groupe.

Switch1(config)#interface port-channel 1
Switch1(config-if)#switchport mode trunk
Switch1(config-if)#switchport trunk allowed vlan 1,100,200,300
Switch1(config-if)#no shutdown
Switch1(config-if)#exit

2) Configuration Switch 2

Nous refaisons la même chose sur le switch 2 :

a) Création des Vlans

Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch2(config)#vlan 100
Switch2(config-vlan)#name SRV
Switch2(config-vlan)#exit
Switch2(config)#vlan 200
Switch2(config-vlan)#name User
Switch2(config-vlan)#exit
Switch2(config)#vlan 300
Switch2(config-vlan)#name Guest
Switch2(config-vlan)#exit

b) Configuration des interfaces

Switch2(config)#interface range gigabitEthernet 0/1 - 2
Switch2(config-if-range)#channel-group 1 mode active
Switch2(config-if-range)#channel-protocol lacp
Switch2(config-if-range)#exit

c) Configuration de l’interface port-channel

Switch2(config)#interface port-channel 1
Switch2(config-if)#switchport mode trunk
Switch2(config-if)#switchport trunk allowed vlan 1,100,200,300
Switch2(config-if)#no shutdown
Switch2(config-if)#exit

III) Test de fonctionnement

On commence par observer si nos ports sont bien configurés dans le bon groupe avec la commande suivante :

show etherchannel 1 summary

Nous obtenons ceci :

Nous regardons ensuite si la bande passante obtenue correspond bien à nos attentes :

show interfaces port-channel 1

On regarde les informations etherchannel :

show etherchannel port-channel

 
 
22 avril 2012  --  N.Salmon
 
 
 
 
Commentaires :
Répondre à cet article
 
 
Se connecter | Copyright © 2016 Idum