Routage OSPF avec authentification MD5
>>> Authentication message-digest
Version PDF

Le but de ce cours n’est pas de vous apprendre à configurer un réseau routé via le protocole OSPF. Le but est de vous apprendre à configurer l’authentification MD5 sur le protocole OSPF. L’authentification va permettre d’éviter qu’un routeur indésirable vienne perturber vos messages OSPF et les tables de routages de votre réseau.


Sommaire :

I) Configuration des routeurs
Routeur 1
Routeur 1-1-1
Routeur 1-1-2
Routeur 1-2-1
Routeur 1-2-2
Routeur 2
Routeur 2-1-1
Routeur 2-1-2
II) Configuration de l’authentification MD5 sur le routeur 1
III) Configuration de l’authentification MD5 sur le routeur 2


I) Configuration des routeurs

Haut de page

Voici notre schéma :

Nous commençons par configurer nos routeurs et le protocole OSPF :

1) Routeur 1

Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#no ip domain-lookup
Router(config)#service password-encryption
Router(config)#hostname Routeur1
Routeur1(config)#interface fastethernet 0/0
Routeur1(config-if)#ip address 172.16.1.1 255.255.255.0
Routeur1(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

Routeur1(config-if)#exit
Routeur1(config)#interface fastethernet 0/1
Routeur1(config-if)#ip address 172.16.2.1 255.255.255.0
Routeur1(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

Routeur1(config-if)#exit
Routeur1(config)#interface fastethernet 1/0
Routeur1(config-if)#ip address 10.0.0.1 255.255.255.0
Routeur1(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet1/0, changed state to up

Routeur1(config-if)#exit
Routeur1(config)#router ospf 1
Routeur1(config-router)#network 172.16.1.0 0.0.0.255 area 1
Routeur1(config-router)#network 172.16.2.0 0.0.0.255 area 2
Routeur1(config-router)#network 10.0.0.0 0.0.0.255 area 0
Routeur1(config-router)#end
Routeur1#wr

Building configuration...
[OK]

2) Routeur 1-1-1

Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#no ip domain-lookup
Router(config)#service password-encryption
Router(config)#hostname Routeur1-1-1
Routeur1-1-1(config)#interface fastethernet 0/0
Routeur1-1-1(config-if)#ip address 172.16.1.2 255.255.255.0
Routeur1-1-1(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

Routeur1-1-1(config-if)#exit
Routeur1-1-1(config)#interface fastethernet 0/1
Routeur1-1-1(config-if)#ip address 192.168.1.1 255.255.255.0
Routeur1-1-1(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

Routeur1-1-1(config-if)#exit
Routeur1-1-1(config)#router ospf 1
Routeur1-1-1(config-router)#network 172.16.1.0 0.0.0.255 area 1
Routeur1-1-1(config-router)#network 192.168.1.0 0.0.0.255 area 1
Routeur1-1-1(config-router)#end
Routeur1-1-1#wr
Building configuration...

[OK]

3) Routeur 1-1-2

Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#no ip domain-lookup
Router(config)#service password-encryption
Router(config)#hostname Routeur1-1-2
Routeur1-1-2(config)#interface fastethernet 0/0
Routeur1-1-2(config-if)#ip address 192.168.1.2 255.255.255.0
Routeur1-1-2(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

Routeur1-1-2(config-if)#exit
Routeur1-1-2(config)#router ospf 1
Routeur1-1-2(config-router)#network 192.168.1.0 0.0.0.255 area 1
Routeur1-1-2(config-router)#end
Routeur1-1-2#wr
Building configuration...
[OK]

4)Routeur 1-2-1

Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#no ip domain-lookup
Router(config)#service password-encryption
Router(config)#hostname Routeur1-2-1
Routeur1-2-1(config)#interface fastethernet 0/0
Routeur1-2-1(config-if)#ip address 172.16.2.2 255.255.255.0
Routeur1-2-1(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

Routeur1-2-1(config-if)#exit
Routeur1-2-1(config)#interface fastethernet 0/1
Routeur1-2-1(config-if)#ip address 192.168.2.1 255.255.255.0
Routeur1-2-1(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

Routeur1-2-1(config-if)#exit
Routeur1-2-1(config)#router ospf 1
Routeur1-2-1(config-router)#network 172.16.2.0 0.0.0.255 area 2
Routeur1-2-1(config-router)#network 192.168.2.0 0.0.0.255 area 2
Routeur1-2-1(config-router)#end
Routeur1-2-1#wr
Building configuration...
[OK]

5) Routeur 1-2-2

Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#no ip domain-lookup
Router(config)#service password-encryption
Router(config)#hostname Routeur1-2-2
Routeur1-2-2(config)#interface fastethernet 0/0
Routeur1-2-2(config-if)#ip address 192.168.2.2 255.255.255.0
Routeur1-2-2(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

Routeur1-2-2(config-if)#exit
Routeur1-2-2(config)#router ospf 1
Routeur1-2-2(config-router)#network 192.168.2.0 0.0.0.255 area 2
Routeur1-2-2(config-router)#end
Routeur1-2-2#wr
Building configuration...
[OK]

6) Routeur 2

Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#no ip domain-lookup
Router(config)#service password-encryption
Router(config)#hostname Routeur2
Routeur2(config)#interface fastethernet 0/0
Routeur2(config-if)#ip address 10.0.0.2 255.255.255.0
Routeur2(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

Routeur2(config-if)#exit
Routeur2(config)#interface fastethernet 0/1
Routeur2(config-if)#ip address 172.16.3.1 255.255.255.0
Routeur2(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

Routeur2(config-if)#exit
Routeur2(config)#router ospf 1
Routeur2(config-router)#network 172.16.3.0 0.0.0.255 area 3
Routeur2(config-router)#network 10.0.0.0 0.0.0.255 area 0
Routeur2(config-router)#end
Routeur2#wr
Building configuration...
[OK]

7) Routeur 2-1-1

Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#no ip domain-lookup
Router(config)#service password-encryption
Router(config)#hostname Routeur2-1-1
Routeur2-1-1(config)#interface fastethernet 0/0
Routeur2-1-1(config-if)#ip address 172.16.3.2 255.255.255.0
Routeur2-1-1(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

Routeur2-1-1(config-if)#exit
Routeur2-1-1(config)#interface fastethernet 0/1
Routeur2-1-1(config-if)#ip address 192.168.3.1 255.255.255.0
Routeur2-1-1(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

Routeur2-1-1(config-if)#exit
Routeur2-1-1(config)#router ospf 1
Routeur2-1-1(config-router)#network 172.16.3.0 0.0.0.255 area 3
Routeur2-1-1(config-router)#network 192.168.3.0 0.0.0.255 area 3
Routeur2-1-1(config-router)#end
Routeur2-1-1#wr
Building configuration...
[OK]

8) Routeur 2-1-2

Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#no ip domain-lookup
Router(config)#service password-encryption
Router(config)#hostname Routeur2-1-2
Routeur2-1-2(config)#interface fastethernet 0/0
Routeur2-1-2(config-if)#ip address 192.168.3.2 255.255.255.0
Routeur2-1-2(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

Routeur2-1-2(config-if)#exit
Routeur2-1-2(config)#router ospf 1
Routeur2-1-2(config-router)#network 192.168.3.0 0.0.0.255 area 3
Routeur2-1-2(config-router)#end
Routeur2-1-2#wr
Building configuration...
[OK]

Notre réseau est configuré. Ensuite on regarde la table de routage du routeur 1 pour vérifier que la configuration fonctionne correctement :

Routeur1#show ip route

Comme on peut le voir tous nos réseaux sont présents.

On vérifie maintenant sur la table de routage du routeur 2 :

Routeur2#show ip route

Tout comme la table de routage précédente, tous nos réseaux sont présent.

II) Configuration de l’authentification MD5 sur le routeur 1

Haut de page

On active l’authentification md5 sur le protocole de routage OSPF de notre routeur 1, plus précisément sur la zone 0 :

Routeur1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Routeur1(config)#interface fastethernet 1/0
Routeur1(config-if)#ip ospf message-digest-key 1 md5 aqw
Routeur1(config-if)#exit
Routeur1(config)#router ospf 1
Routeur1(config-router)#area 0 authentication message-digest
Routeur1(config-router)#end
Routeur1#wr

L’authentification OSPF s’active sur l’interface connectée au réseau que l’on souhaite sécurisé. Dans notre cas nous souhaitons sécuriser la connexion sur area 0 entre l’interface fa1/0 du routeur1 et l’interface fa0/0 du routeur 2. Nous tapons donc la commande "ip ospf message-digest-key 1 md5 aqw" sur notre interface fa1/0 (aqw étant notre mot de passe). Nous configurons ensuite le type d’authentification sur le routeur OSPF via la commande : "area 0 authentication message-digest".

Notre routeur 2 n’ayant pas l’authentification configurée, observons ce qu’il se passe dans la table de routage du routeur 1 :

Routeur1#show ip route

Nous observons que les routes des areas 1 et 2 sont présentes. Mais l’area 3 n’est pas dans la table. Si nous faisons un "debug ip ospf events" :

On peut voir que notre routeur1 reçoit bien les messages du routeur 2 mais il les ignore car le routeur 2 ne lui envoie pas d’authentification.

III) Configuration de l’authentification MD5 sur le routeur 2

Haut de page

On active l’authentification md5 sur le protocole de routage OSPF de notre routeur 2 :

Routeur2#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Routeur2(config)#interface fastethernet 0/0
Routeur2(config-if)#ip ospf message-digest-key 1 md5 aqw
Routeur2(config-if)#exit
Routeur2(config)#router ospf 1
Routeur2(config-router)#area 0 authentication message-digest
Routeur2(config-router)#end
Routeur2#wr

Voilà la configuration est terminée, observons maintenant :

Sur notre routeur 1 :

Routeur1#show ip route

Sur notre routeur 2 :

Routeur2#show ip route

Les deux tables de routage sont complètes, donc l’authentification a bien fonctionné.

 
 
18 novembre 2010  --  N.Salmon
 
 
 
 
Commentaires :
Répondre à cet article

  •  Routage OSPF avec authentification MD5    > 2 octobre 11:33, par NL

    Il manque la topologie réseau


    •  Routage OSPF avec authentification MD5    > 23 octobre 22:03, par N.Salmon

      Bonjour,

      Problème corrigé.

      Merci et à Bientôt.


  •  Routage OSPF avec authentification MD5    > 25 septembre 2013 10:45, par ibil17

    revoir la config du routeur 2. area 2 ou area 3 ?


    •  Routage OSPF avec authentification MD5    > 3 octobre 2013 17:42, par N.Salmon

      Bonjour,

      Désolé du retard pour la réponse.

      Effectivement il y avait bien une petite erreur. sur le routeur 2 le réseau "network 172.16.3.0 0.0.0.255" est bien dans l’area ospf 3.

      J’ai modifié l’article.

      Merci :)


  •  Routage OSPF avec authentification MD5    > 25 septembre 2013 10:43, par ibil17

    Revoir la config du routeur 2.1, c’est peut être moi qui fait une erreur mais j’ose croire que l’area est 3 au lieu de 2.

 
 
Se connecter | Copyright © 2016 Idum