Configuration AP wifi avec multi-SSID (mbssid)
>>> mbssid sur AP Wifi Cisco
Version PDF

Dans ce cours nous allons apprendre à configurer une AP Wifi Cisco pour qu’elle puisse diffuser plusieurs SSID, chaque SSID sera relié à un Vlan différent.


Sommaire :

I) Explications
II) Configuration du Switch
III) Configuration de l’AP Wifi
IV) Test de connexion


I) Explications

Voici le schéma de notre réseau :

Comme on peut le remarquer notre AP wifi est connecté au switch via un seul câble. Mais elle diffuse deux noms de réseau différents, chaque nom diffusé appelé SSID est connecté à un réseau virtuel différent (réseau virtuel appelé aussi Vlan).

II) Configuration du Switch

Commençons par le plus simple, la configuration de notre switch.

Switch#configure terminal

Switch(config)#vlan 100

Switch(config-vlan)#name Reseau1

Switch(config-vlan)#exit

Switch(config)#vlan 200

Switch(config-vlan)#name Reseau2

Switch(config-vlan)#exit

On vient de créer les vlans.

Switch(config)#interface fastethernet 0/1

Switch(config-if)#switchport mode trunk

Switch(config-if)#switchport trunk native vlan 1

Switch(config-if)#switchport trunk allowed vlan 1,100,200

Switch(config-if)#no shutdown

Switch(config-if)#exit

Voilà nous avons configuré le port fa0/1 du switch en mode trunk pour pouvoir faire circuler les vlans 1, 100 et 200 sur la même interface.

III) Configuration de l’AP Wifi

Maintenant nous allons configurer notre AP Wifi. Nous commencerons par la configuration de base, puis nous configurons les deux SSID.

Commencez par taper ces deux commandes permettant d’activer le pont entre les interfaces wifi, et fastethernet :

AP#configure terminal

AP(config)#bridge irb

AP(config)#bridge 1 route ip

AP(config)#end

Sur une AP wifi Cisco, on ne configure pas l’adresse IP sur l’interface ethernet comme avec les routeurs mais sur l’interface BVI, cette adresse IP va en autre vous permettre de configurer votre AP grâce à l’interface graphique que nous allons activer ci-dessous :

AP#configure terminal

AP(config)#interface BVI 1

AP(config-if)#ip address 192.168.1.249 255.255.255.0

AP(config-if)#no shutdown

AP(config-if)#end

Ensuite si vous le souhaitez vous pouvez activer l’interface graphique de l’AP, mais ce n’est pas obligatoire pour continuer la configuration :

AP#configure terminal

AP(config)#ip http secure-server

AP(config)#end

Je vous conseille de configurer un routeur par défaut, qui vous permettra de rediriger tous les paquets vers la passerelle et ainsi gagner du temps dans la gestion des paquets destiné à un réseau différents de celui de l’AP :

AP#configure terminal

AP(config)#ip default-gateway 192.168.1.254

AP(config)#end

Voilà maintenant nous allons configurer les deux SSID :

AP#configure terminal

AP(config)#dot11 vlan-name Reseau1 vlan 100

AP(config)#dot11 vlan-name Reseau2 vlan 200

AP(config)#dot11 ssid Reseau1

AP(config-ssid)#vlan 100

AP(config-ssid)#authentication open

AP(config-ssid)#mbssid guest-mode

AP(config-ssid)#exit

AP(config)#dot11 ssid Reseau2

AP(config-ssid)#vlan 200

AP(config-ssid)#authentication open

AP(config-ssid)#mbssid guest-mode

AP(config-ssid)#exit

On configure l’interface radio 0 :

AP(config)#interface Dot11Radio0

AP(config-if)#mbssid

AP(config-if)#encryption vlan 100 mode wep mandatory

AP(config-if)#encryption vlan 100 key 1 size 128bit 7 A1B2C3D4E5F6A1B2C3D4E5F6A1

AP(config-if)#encryption vlan 200 mode wep mandatory

AP(config-if)#encryption vlan 200 key 1 size 128bit 7 A1B2C3D4E5F6A1B2C3D4E5F6A1

AP(config-if)#ssid Reseau1

AP(config-if)#ssid Reseau2

AP(config-if)#no shutdown

AP(config-if)#exit

AP(config)#interface Dot11Radio0.100

AP(config-subif)#encapsulation dot1Q 100

AP(config-subif)#bridge-group 100

AP(config-subif)#no shutdown

AP(config-subif)#exit

AP(config)#interface Dot11Radio0.200

AP(config-subif)#encapsulation dot1Q 200

v(config-subif)#bridge-group 200

AP(config-subif)#no shutdown

AP(config-subif)#exit

On configure l’interface radio 1 :

AP(config)#interface Dot11Radio1

AP(config-if)#mbssid

AP(config-if)#encryption vlan 100 mode wep mandatory

AP(config-if)#encryption vlan 100 key 1 size 128bit 7 A1B2C3D4E5F6A1B2C3D4E5F6A1

AP(config-if)#encryption vlan 200 mode wep mandatory

AP(config-if)#encryption vlan 200 key 1 size 128bit 7 A1B2C3D4E5F6A1B2C3D4E5F6A1

AP(config-if)#ssid Reseau1

AP(config-if)#ssid Reseau2

AP(config-if)#no shutdown

AP(config-if)#exit

AP(config)#interface Dot11Radio0.100

AP(config-subif)#encapsulation dot1Q 100

AP(config-subif)#bridge-group 100

AP(config-subif)#no shutdown

AP(config-subif)#exit

AP(config)#interface Dot11Radio0.200

AP(config-subif)#encapsulation dot1Q 200

AP(config-subif)#bridge-group 200

AP(config-subif)#no shutdown

AP(config-subif)#exit

On configure l’interface fastethernet 0 :

AP(config)#interface FastEthernet0

AP(config-if)#bridge-group 1

AP(config-if)#no shutdown

AP(config-if)#exit

AP(config)#interface FastEthernet0.100

AP(config-subif)#encapsulation dot1Q 100

AP(config-subif)#bridge-group 100

AP(config-subif)#no shutdown

AP(config-subif)#exit

AP(config)#interface FastEthernet0.200

AP(config-subif)#encapsulation dot1Q 200

AP(config-subif)#bridge-group 200

AP(config-subif)#no shutdown

AP(config-subif)#exit

Voilà si vous avez bien suivi la configuration il ne vous reste plus qu’à sauvegarder.

AP(config)#end

AP(config)#wr

IV) Test de connexion

Essayons de nous connecter pour vérifier que les réseaux wifi fonctionnent bien.

Cliquez en bas à droite, à côté de l’horloge sur le logo représentant le wifi. Vous pouvez observer que nos deux SSID sont bien diffusé par l’AP. Faites un double clique sur Reseau1 pour vous connecter.

Entrez la clef WEP.

On peut maintenant observer que nous somme bien connecté.

PS : ATTENTION l’authentification WEP est obsolète, elle n’est plus considéré comme une sécurité à part entière, car elle est facile à pirater.

 
 
30 septembre 2010  --  N.Salmon
 
 
 
 
Commentaires :
Répondre à cet article
 
 
Se connecter | Copyright © 2016 Idum