Routage Inter-Vlans
>>> Router des paquets entre différents Vlans
Version PDF

Le but de ce cours est de vous apprendre à configurer un routeur pour réaliser du routage inter-vlans.


Sommaire :

I) Configuration de Vlans
1) Switch1
2) Switch2
3) Switch0
II) Configuration Inter-Vlans
1) Switch0
2) Routeur


I) Configuration de Vlans

Voici notre schéma de réseau :

Récapitulatif des adresses IP :

Nom PC1-Vlan100 PC2-Vlan100 PC1-Vlan200 PC2-Vlan200 PC1-Vlan300 PC2-Vlan200
Adresse IP 10.10.0.1 10.10.0.2 10.20.0.1 10.20.0.2 10.30.0.1 10.30.0.2
Masque 255.255.0.0 255.255.0.0 255.255.0.0 255.255.0.0 255.255.0.0 255.255.0.0
Gateway 10.10.0.254 10.10.0.254 10.20.0.254 10.20.0.254 10.30.0.254 10.30.0.254
Vlan vlan 100 vlan 100 vlan 200 vlan 200 vlan 300 vlan 300

1) Switch1

Nous commençons par configurer le Switch1. On va lui donner un nom, on va lui dire de ne pas résoudre les noms (commandes "no ip domain-lookup"), et on va déclarer les Vlans :

Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname Switch1
Switch1(config)#no ip domain-lookup
Switch1(config)#vlan 100
Switch1(config-vlan)#exit
Switch1(config)#vlan 200
Switch1(config-vlan)#exit

Nous intégrons ensuite les interfaces dans les Vlans :

Switch1(config)#interface fastEthernet 0/1
Switch1(config-if)#switchport mode access
Switch1(config-if)#switchport access vlan 100
Switch1(config-if)#exit
Switch1(config)#interface fastEthernet 0/2
Switch1(config-if)#switchport mode access
Switch1(config-if)#switchport access vlan 200
Switch1(config-if)#exit

Et pour finir nous créons le lien trunk permettant aux Vlans d’échanger entre eux.

Switch1(config)#interface fastEthernet 0/24
Switch1(config-if)#switchport mode trunk
Switch1(config-if)#switchport trunk native vlan 1
Switch1(config-if)#switchport trunk allowed vlan 100
Switch1(config-if)#switchport trunk allowed vlan add 200

2) Switch2

Nous continuons ensuite avec le switch2 :

Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname Switch2
Switch2(config)#no ip domain-lookup
Switch2(config)#vlan 100
Switch2(config-vlan)#exit
Switch2(config)#vlan 300
Switch2(config-vlan)#exit

Nous intégrons ensuite les interfaces dans les Vlans :

Switch2(config)#interface fastEthernet 0/1
Switch2(config-if)#switchport mode access
Switch2(config-if)#switchport access vlan 300
Switch2(config-if)#exit
Switch2(config)#interface fastEthernet 0/2
Switch2(config-if)#switchport mode access
Switch2(config-if)#switchport access vlan 100
Switch2(config-if)#exit

Et pour finir nous créons le lien trunk permettant aux Vlans d’échanger entre eux.

Switch2(config)#interface fastEthernet 0/24
Switch2(config-if)#switchport mode trunk
Switch2(config-if)#switchport trunk native vlan 1
Switch2(config-if)#switchport trunk allowed vlan 100
Switch2(config-if)#switchport trunk allowed vlan add 300

3) Switch0

Pour finir nous configurons le Switch0, qui est notre switch central.

Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname Switch0
Switch0(config)#no ip domain-lookup
Switch0(config)#vlan 100
Switch0(config-vlan)#exit
Switch0(config)#vlan 200
Switch0(config-vlan)#exit
Switch0(config)#vlan 300
Switch0(config-vlan)#exit

Nous intégrons ensuite les interfaces dans les Vlans :

Switch0(config)#interface fastEthernet 0/1
Switch0(config-if)#switchport mode access
Switch0(config-if)#switchport access vlan 200
Switch0(config-if)#exit
Switch0(config)#interface fastEthernet 0/2
Switch0(config-if)#switchport mode access
Switch0(config-if)#switchport access vlan 300
Switch0(config-if)#exit

Et nous configurons les 2 ports qui nous servent de lien trunk.

Switch0(config)#interface fastEthernet 0/22
Switch0(config-if)#switchport mode trunk
Switch0(config-if)#switchport trunk native vlan 1
Switch0(config-if)#switchport trunk allowed vlan 100
Switch0(config-if)#switchport trunk allowed vlan add 200
Switch0(config-if)#exit
Switch0(config)#interface fastEthernet 0/23
Switch0(config-if)#switchport mode trunk
Switch0(config-if)#switchport trunk native vlan 1
Switch0(config-if)#switchport trunk allowed vlan 100
Switch0(config-if)#switchport trunk allowed vlan add 300
Switch0(config-if)#exit

Si nous réalisons quelques tests, nous pouvons observer que :

- PC1-Vlan100 vers PC2-VLAN100 fonctionne bien
- PC1-Vlan200 vers PC2-VLAN200 fonctionne bien
- PC1-Vlan300 vers PC2-VLAN300 fonctionne bien

Mais nous observons aussi que les ping entre les PCs qui ne sont pas dans le même vlan ne fonctionnent pas.

II) Configuration Inter-Vlans

Pour que les machines puissent se pinger entre elles, même si elles ne font pas partie du même vlan, il faut ajouter un routeur. Ne pouvant pas utiliser un câble par vlan qui serait trop encombrant et trop onéreux suivant le nombre de vlan, nous utilisons à la place le routeur Inter-vlans. Le routage inter-vlans consiste à faire passer tous les vlans dans un seul lien via un lien trunk connecté à des sous-interfaces sur notre routeur en déclarant le vlan auquel elles appartiennent.

Voici notre nouveau plan réseau :

1) Switch0

Nous commençons par configurer un lien trunk sur notre Switch0 :

Switch0(config)#interface fastEthernet 0/24
Switch0(config-if)#switchport mode trunk
Switch0(config-if)#switchport trunk native vlan 1
Switch0(config-if)#switchport trunk allowed vlan 100
Switch0(config-if)#switchport trunk allowed vlan add 200
Switch0(config-if)#switchport trunk allowed vlan add 300
Switch0(config-if)#exit

2) Routeur

Nous nous attaquons ensuite à la configuration de notre routeur :

Nous configurons son nom et on lui désactive la résolution de nom.

Router#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname Routeur
Routeur(config)#no ip domain-lookup

On active ensuite l’interface fastethernet 0/0

Routeur(config)#interface fastEthernet 0/0
Routeur(config-if)#no shutdown
Routeur(config-if)#exit

On déclare la première sous-interface :

Routeur(config)#interface fastEthernet 0/0.100

Nous déclarons ensuite le type d’encapsulation trunk ainsi que le Vlan :

Routeur(config-subif)#encapsulation dot1Q 100

Et nous terminons par la configuration de l’adresse IP et l’activation de la sous-interface :

Routeur(config-subif)#ip address 10.10.0.254 255.255.0.0
Routeur(config-subif)#no shutdown
Routeur(config-subif)#exit

Nous refaisons la même chose pour les deux autres Vlans :

Routeur(config)#interface fastEthernet 0/0.200
Routeur(config-subif)#encapsulation dot1Q 200
Routeur(config-subif)#ip address 10.20.0.254 255.255.0.0
Routeur(config-subif)#no shutdown
Routeur(config-subif)#exit
Routeur(config)#interface fastEthernet 0/0.300
Routeur(config-subif)#encapsulation dot1Q 300
Routeur(config-subif)#ip address 10.30.0.254 255.255.0.0
Routeur(config-subif)#no shutdown
Routeur(config-subif)#exit

Si nous recommençons nos test, nous pouvons observer que :

- PC1-Vlan100 vers PC2-VLAN100 fonctionne bien
- PC1-Vlan200 vers PC2-VLAN200 fonctionne bien
- PC1-Vlan300 vers PC2-VLAN300 fonctionne bien

Comme précédemment, mais que les ping entre Vlans fonctionnent aussi, par exemple :

- PC1-Vlan100 vers PC1-VLAN200 fonctionne bien
- PC1-Vlan200 vers PC1-VLAN300 fonctionne bien
- PC2-Vlan300 vers PC1-VLAN100 fonctionne bien

Vous pouvez télécharger le fichier Packet tracert en cliquant sur le lien ci-dessous :

PNG - 12.3 ko
 
 
2 juin 2010  --  N.Salmon
 
 
 
 
Commentaires :
Répondre à cet article

  •  Routage Inter-Vlans    > 31 mars 2015 14:28, par KONATE

    je tiens à vous remercier pour cet article sur le routage inter-vlan.
    vous m’avez permis de comprendre la notion du vlan
    j’admire beaucoup votre site il est très intéressant. vous êtes très explicite dans tous les cours que vous présentez.
    merci infiniment

 
 
Se connecter | Copyright © 2016 Idum